Irfanview

A free image editor




 

Contents of this Help Topic

Go to Installing Irfanview

Go to Using Irfanview

Go to Graphics Tutorial

Go to Irfanview Thumbnails

 

Irfanview is a freeware image editing program written by Irfan Skiljan while attending the Vienna University of Technology. The program can display, convert, resize, and edit graphics files. It however does not have extensive image manipulation features like Adobe Photoshop or the open source program GIMP.

It is ideal for resizing and cleaning up digital camera photos. Have you received an email with a photo attached that is so big that you can only see a portion of the picture? Irfanview can fix that.

 

Installing Irfanview

 

When installing Irfanview you will be asked to make a number of choices. These questions are instructive on graphics files so we will cover the installation in detail. This Help Topic presumes that you are familiar with downloading programs from the Internet. If not, see the Help Topic on Downloads.

Go to the Irfanview site. There you will find Irfanview and Irfanview plugins. You want them both. The plugins will allow Irfanview to display movies and provide additional functions like email and scanners.

One of the interesting features of Irfanview is that it is capable of displaying unusual graphics files like CAD. Before Irfanview one needed an expensive CAD program.

Irfanview

 

Again, this lesson presumes you have already downloaded Irfanview and put the installer somewhere on your computer according to the download Help Topic.

We will now go through the install process.

Double click on the Irfanview installer and Run at the security warning that the publisher could not be verified.

On this first Irfanview Setup screen, take all the defaults and click the Next> button.

Irfanview Install 1

 

The next menu tells you the new features in this release of Irfanview. Just click Next>.

Irfanview Install 2

 

Here the installer shows you the graphics file types that Irfanview can handle. If you don't understand all the file types, click on Select all to make Irfanview your default image viewer. If you have other image software on your computer you can select what file types you want Irfanview to handle. In either case all the file types will be restored to your original settings if you uninstall Irfanview.

Then click Next>.

Irfanview Install 3

 

The next menu wants you to install a fairly worthless toolbar. Uncheck Install free toolbar. Then click Next>.

Irfanview Install 4

 

The next screen allows you to select a folder for the .ini file. Just click Next> to install Irfanview.

Irfanview Install 5

 

You now get a screen confirming a successful Irfanview Installation. Click Done to begin using Irfanview.

Irfanview Install Done

 

You will then be taken to the Irfanview FAQ. This explains issues and provides help for the current release. Just close the FAQ screen.

Irfanview FAQ

 

Irfanview install will put two new icons on your desktop. Irfanview and Irfanview Thumbnails.

Irfanview Icon Irfanview Thumbnails

Next install the Irfanview Plugins by double clicking on the on a file called irfanviewIrfanview_plugins_xxx_setup.exe located in the same folder as the Irfanview setup program. There are no prompts for the plugins setup, only the standard Windows security warning but Irfanview must not be running.

You are now at the Irfanview main screen.

 

Using Irfanview

 

Most of the buttons will look familiar if you if you have used a Word Processors but these act on images.

Generally it's easiest to learn by doing so we will start by resizing a picture to be sent as an email attachment.

Irfanview M<ain Screen

 

Graphics Tutorial

Before we get into resizing a short tutorial on graphics is in order.

Images are displayed on a computer screen in pixels. Pixel is short for Picture Element.

LCD Pixel

If you look at a computer display with a magnifying glass (here a flat panel display), you will see the pixels. They are the red, green, blue and black spots shown at the left. An image or picture is displayed by the amount of red,green or blue in each spot.

Looking at this image we see red, green and blue (R,G,B) spots of about the same brightness. This produces white on the screen. The lesser intensity R,G,B at the far left produces gray and the darker area in the lower right is black - the absence of all colors.

That is the reason a computer display is sometimes referred to as an R,G,B display. This method of mixing colors is called the RGB Color Model. The other color mixing model used on computers is the CMYK Color Model used in printing. This explains why colors sometimes do not look the same on the screen and when printed.

If you count the pixels on any computer screen you will find that there are 72 of them per inch. Computer displays have a resolution of 72 Dots Per Inch or dpi.

On the other hand printers have a resolution of 300 dpi. This is why printed pictures do not look as good as pictures on the screen. If you take a good picture on the screen, blow it up to an 8x10 size and print it, you will find that it pixelates when printed.

Now back to Irfanview.

We have a brand new high end digital camera and take a picture that we want to send to a friend. The picture is on an SD card and is named DSC_0004.jpg. Every digital camera has its own picture naming scheme.

To open the picture, start Irfanview, click on File, Open and find the SD Card. Click on DSC_0004.jpg to open the picture.

Irfanview

 

Our digital camera takes pictures at a resolution of 3872x2592 and 300 dpi. This makes our picture a 1.2mb file. To big to send in an email. We know this because we clicked on Image and Information. Picture

 

This is the Irfanview Image Information screen. It shows the the important properties of our image. Click the OK button to close and we are back at our picture.

Image Information

 

We are going to email this picture so it is way too big now. The first thing we notice is that it is 300 dpi. Remember that a computer monitor can only display 72dpi. Click on Image and Resize/Resample.... irfan-15.jpg 645x463

 

Resize/Resamole

 

 

 

 

Where we get the Resize/Resample... menu.

The first thing we want to do is change the DPI to 72 because that is all that can be displayed on any computer monitor.

We want to preserve the Aspect Ratio so we will leave that box checked.

Notice the Standard Dimensions at the top right of this menu. This gives the standard computer monitor resolutions that match your picture resolution.

We pick the smallest size 640x480 and then click the Half button to cut that size in half.

Then click the OK button.

 

 

 

 

We now have a resized picture. But it is not saved in the new size. We want to save it in the new size so we will click on File and Save as...and pick a new folder and name of DSC_0004-1 for the resized new file and save it.

Picture Resized

 

To send the file in an email all we have to do is click on Options and Send file by Email.... Irfanview will bring up your default email program with this picture attached.

Irfanview Tools

 

Open the file we saved earlier, now called DSC_0004-1. Then click on the magnifying glass with a + sign to increase the image size in Irfanview. This is not increasing the filesize, it is only increasing the image size on the screen so you can see it better.

Notice the under exposed area in the lower right side of the picture. Irfanview can fix this.

Click on Image and Color corrections. Our picture

 

Irfanview Color Correction

 

 

This will open the Color Corrections panel. You will see two pictures. The left picture shows your image as it is, The right image shows the same after image color corrections have been made.

Grab the slider on Gamma correction with your left mouse button and hold it while moving the mouse right and left. The slider will move and you will see the results of that correction in the right image.

Try moving the other sliders to see what they do to the image.

When the picture looks good, click OK to save the changes.

If you're unhappy with the changes simply click Cancel to close Color Corrections.

You can also let Irfanview make all all color corrections by clicking on Image and Auto adjust colors.

 

 

 

Now look at the other things Image can do.

You can free rotate the image right or left. This is useful if the camera is tilted when the picture is taken, you can flip the image by 90° or 180°.

You can change the color depth, convert it to B&W (Greyscale), or eliminate red eyes.

Image Options

 

Effects

 

 

 

If you click on Effects... you get the Effects menu as shown here.

With effects you can do things like blur the image, add brush strokes, apply various filters, or turn it into a Sepia photo.

You can also download more effects by clicking on Filter Factory... or Filters Unlimited....

These are both web sites that offer effects plugins for Irfanview.

 

The Adobe 8BF filters also work with Irfanview, but they are not free.

 

 

 

 

Options menu

 

Another menu of interest is Options shown here.

 

In the Options menu you can change the file types associated with Irfanview. This determines what file types will cause Irfanview to open as we selected earlier in the setup. Then we selected all graphics file types but we can change that decision here by clicking Change file associations...

 

We can change the amount of image compression in a JPEG file.

 

We can capture a screenshot,

add a scanner TWAIN device,

or start using a scanner.

 

In short this allows us to control how Irfanview operates.

 

 

Now we will crop a section of the original picture and create a new picture of that section.

First, open the original picture again an click the - magnifying glass until the picture fits on the screen.

Then select an area of interest with the mouse, hold down the left mouse button and draw a box around the area of interest.

And click Cut. That's the scissors icon. Full Picture

 

That section of the picture disappeared. Irfanview placed the cropped section on the Windows clipboard.

Then move the cursor outside of the cropped section and click Paste. The clipboard with a scrap of paper.

section cut

 

Irfanview will place the cropped section on the screen. The window will resize to the cropped section size.

We have used the - magnifier to resize the picture.

We can now save that section as a new picture or use Effects to further manipulate the picture.

irfan-27.jpg 607x700

 

That's about all we can teach about using Irfanview. The one last topic is Irfanview Thumbnails   Thumbnails Icon   The other icon Irfanview install put on our desktop.

 

Irfanview Thumbnails

Click on the Irfanview Thumbnails icon on your desktop.

This allows you to search for your digital photos. And this brings up the subject of organization.

My method is to have a folder in the root directory called Photo File in which I have all my photos. In that directory there is a sub-directory called RAW in which I store pictures from my various cameras exactly as they were taken.

Then there are sub-directories by subject. These contain finalized pictures that have been cleaned up with Irfanview or another Graphics Editor.

Here we scroll down in Photo File folder and display the Maggie sub-directory where all the cleaned pictures of my dog are kept. The directory structure is on the left with thumbnails of the pictures on the right.

Tp view any of these pictures in Irfanview simply double click on the picture.

Irfanview Thumbnails

 

Now go find the pictures on your computer with Irfanview Thumbnails and consider my method of photo organization. If you're not familiar with Files and Folders consider taking our course with that name.

That's it. Now go install Irfanview on your compute and start using it.